Appointment reminder delays
Incident Report for SimplePractice
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 12:18 PDT
Investigating
Our engineering team is currently investigating an issue with the delivery of some appointment reminders.
Posted Apr 25, 2022 - 11:13 PDT
This incident affected: Email Service and SMS Service.