Telehealth Service may be degraded on Safari

Incident Report for SimplePractice

Update

We are currently experiencing a limited feature interruption related to Telehealth appointments on Safari.

Our Engineering team is monitoring this situation as our vendor works to resolve the issue.

We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted Apr 10, 2026 - 13:07 PDT

Investigating

We are currently investigating this issue.
Posted Apr 10, 2026 - 12:21 PDT
This incident affects: Main application and Telehealth Service.