Save button for Availability is inaccessible

Incident Report for SimplePractice

Resolved

A fix has been released for this issue and it has been resolved.
Posted Nov 17, 2025 - 05:11 PST

Update

We are continuing to work on a fix for this issue.
Posted Nov 15, 2025 - 20:14 PST

Update

We are continuing to work on a fix for this issue.
Posted Nov 15, 2025 - 14:59 PST

Identified

We've been alerted to an issue where customers may have issues accessing the Save button when creating or editing blocks of availability, and will be working to have this resolved as soon as we can.

If met with this issue we've noted that decreasing the Zoom on your browser will allow you to access the Save button to create or make changes to existing blocks of availability.
Posted Nov 15, 2025 - 11:10 PST
This incident affected: Main application.