Appointment Requests

Incident Report for SimplePractice

Resolved

This issue has now been resolved.
Posted Aug 31, 2026 - 07:32 PDT

Monitoring

A fix has been implemented for this and we are currently monitoring the situation.
Posted Aug 31, 2026 - 07:16 PDT

Identified

We have identified the cause of the issue and are actively working on a fix.
Posted Aug 31, 2026 - 06:21 PDT

Investigating

We are currently seeing an issue with appointment requests appearing on the Requests page.
Posted Aug 31, 2026 - 06:11 PDT
This incident affected: Main application.