Credit card transaction issues
Incident Report for SimplePractice
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 22:07 PST
Monitoring
There was a temporary outage that prevented some customers from processing credit card payments. We are monitoring the status of this issue.
Posted Feb 27, 2024 - 17:32 PST
Investigating
We are currently investigating this issue.
Posted Feb 27, 2024 - 15:51 PST
This incident affected: Online Payments Service.