Limited Feature Interruption

Incident Report for SimplePractice

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 12:00 PDT

Monitoring

We've implemented a fix for this, and are currently monitoring the results.
Posted Mar 19, 2026 - 11:42 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 19, 2026 - 11:24 PDT

Identified

The issue has been identified, and a fix is being implemented. We'll be following up as we have more information to share.
Posted Mar 19, 2026 - 10:36 PDT

Investigating

We are currently experiencing a limited feature interruption related to opening appointments and loading the information in Client Overview pages.

We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted Mar 19, 2026 - 10:22 PDT
This incident affected: Main application.