Pages may be slow loading
Incident Report for SimplePractice
Resolved
This incident has been resolved and we are currently monitoring for any further issues.
Posted Apr 23, 2024 - 13:08 PDT
Monitoring
The site had been experiencing a higher than normal amount of load, and may have caused pages to be slow or unresponsive.

Our Engineering team has identified the root cause and is currently monitoring for any further issues.

We know that this could impact your workflow, and our team is working hard to resolve this as quickly as possible. Rest assured that your data is safe.

We will continue to provide updates until we reach a resolution.
Posted Apr 23, 2024 - 10:48 PDT
This incident affected: Main application.