Limited Feature Interruption

Incident Report for SimplePractice

Resolved

This incident has been resolved.
Posted May 06, 2025 - 11:16 PDT

Monitoring

A fix has been released and we are monitoring the results.
Posted May 06, 2025 - 10:18 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 06, 2025 - 09:13 PDT

Investigating

We are currently experiencing a limited feature interruption related to new team member sign ups.

We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted May 06, 2025 - 08:58 PDT
This incident affected: Main application.