Unable to login

Incident Report for SimplePractice

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jul 22, 2026 - 14:39 PDT

Monitoring

A fix has been released and we are monitoring the results.
Posted Jul 22, 2026 - 12:27 PDT

Identified

We have identified the cause of the heavy load issue preventing users from signing in and scheduling appointments. We are working quickly to release a fix.
Posted Jul 22, 2026 - 11:19 PDT
This incident affected: Main application.