Limited Feature Interruption - Professional Website
Incident Report for SimplePractice
Resolved
This incident has been resolved.
Posted Sep 22, 2024 - 13:38 PDT
Investigating
We are currently experiencing a limited feature interruption related to Professional Websites.

We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted Sep 22, 2024 - 12:11 PDT
This incident affected: Main application.