Calendar Location Filters

Incident Report for SimplePractice

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 11:42 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 10:38 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2026 - 09:46 PDT

Investigating

We are currently experiencing an issue where your Calendar Location filter may uncheck when filtering by locations this may cause appointments to disappear from the Calendar.

We are actively working to resolve this issue as quickly as possible, for the time being if you experience this issue please re-check the filter as needed.

More updates to follow shortly.
Posted Jun 11, 2026 - 09:27 PDT
This incident affects: Main application.