We're still in the process of monitoring the fix for this, and will continue to provide updates as we have them.
Posted Jul 10, 2025 - 13:26 PDT
Monitoring
We've implemented the fix for this and are currently monitoring this further.
Posted Jul 10, 2025 - 11:02 PDT
Update
We are continuing to work on a fix for this.
Posted Jul 10, 2025 - 10:29 PDT
Identified
We've identified the issue and are currently in the process of implementing a fix for this.
Posted Jul 10, 2025 - 09:59 PDT
Investigating
We have identified delays in message delivery of automated email reminders, daily agenda emails, and Data Export processing.
To ensure appropriate communication with clients, please manually send the appointment reminders from the appointment page. It is recommended that customers use alternate forms of communication for the duration of this incident.
We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted Jul 10, 2025 - 09:26 PDT
This incident affected: Main application and Email Service.