Connectivity issues have been resolved. We appreciate your patience.
Posted Oct 21, 2025 - 05:16 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 15:44 PDT
Monitoring
The affected areas of our platform are in the process of recovering, and we are continuing to monitor this further. We will follow up when we have more information to share.
Posted Oct 20, 2025 - 13:46 PDT
Update
Users may still be experiencing issues with various areas of the platform including Telehealth, ePrescribe, and insurance enrollments. We're continuing to work to resolve these issues.
We'll continue to provide further information as we have it.
Posted Oct 20, 2025 - 11:15 PDT
Update
Users may experience continued issues with various areas of the platform including Telehealth and ePrescribe. We're currently investigating and working to resolve these issues.
We will continue to provide updates as we have them.
Posted Oct 20, 2025 - 09:35 PDT
Investigating
Users may be experiencing issues with connecting to Telehealth appointments.
We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted Oct 20, 2025 - 07:52 PDT
This incident affected: Main application and Telehealth Service.