Repeat pending document notifications

Incident Report for SimplePractice

Resolved

A fix for this issue has been released and is now resolved.
Posted May 12, 2025 - 05:20 PDT

Identified

We are currently experiencing a limited feature interruption related to notifications. Some customers may be experiencing repeat notifications regarding pending documents.

We are working to resolve this issue.
Posted May 10, 2025 - 16:02 PDT

Investigating

We are currently experiencing a limited feature interruption related to notifications. Some customers may be experiencing repeat notifications regarding pending documents.

We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted May 10, 2025 - 14:41 PDT
This incident affected: Main application.