Customers unable to create appointments

Incident Report for SimplePractice

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 06:15 PDT

Monitoring

We've identified the issue, implemented a fix, and are now monitoring the results. We will follow up once we have more information to share.
Posted Sep 04, 2026 - 06:01 PDT

Investigating

Users may be experiencing issues when creating appointments. We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted Sep 04, 2026 - 05:45 PDT
This incident affected: Main application.